time 
设为首页】【收藏本站
当前位置: 主页 > 程序设计 > .net > Visual Studio > 关于nunit调试VS2010中的4.0程序集的问题

关于nunit调试VS2010中的4.0程序集的问题

时间:2010-08-15 22:34 点击:2608次 字体:[ ]




 目前nunit的老版本不支持.net framework 4.0程序的测试。运行4.0程序集需要下载nunit的新版本 http://www.nunit.org/

 

  目前我使用的版本是nunit 2.5.5,但是发现下断点了以后不能调试。于是gogole了一下,发现这篇文章http://frater.wordpress.com/2010/05/04/debugging-nunit-tests-under-visual-studio-2010/

 

  其中,有两个配置 nunit.exe.config 步骤:

 

  1. 在 <configuration> 下 加

...

   
<startup>  
      
<requiredRuntime version="v4.0.30319" />
   
</startup>

 

 

  2.  在 <runtime> 加

 

<runtime> 

...


  <loadFromRemoteSources enabled="true" />


...

</runtime> 

 

 

  其中loadFromRemoteSources 的配置选项为:<loadFromRemoteSources enabled="true|false" />

 

  另外,更加你的.net framework版本选择是哪个版本:v4.0.20506 和 4.0.30319

  如果是4.0.30319配置为:<requiredRuntime version="v4.0.30319" />  

  如果是4.0.20506 配置为:<requiredRuntime version="v4.0.20506" />  

 

 

  转自:  http://www.cnblogs.com/GoodHelper/archive/2010/06/23/vs2010_nunit_debug.html



本文地址 : http://www.fengfly.com/plus/view-186629-1.html
标签: VS2010 NUnit
------分隔线----------------------------
最新评论 查看所有评论
发表评论 查看所有评论
请自觉遵守互联网相关的政策法规,严禁发布色情、暴力、反动的言论。
评价:
表情:
验证码: